
 

State of Oklahoma 
Department of Central Services 
Central Purchasing 

Solicitation Package 
Instructions for MS Word 2003 with 

Service Pack 3 

TABLE OF CONTENTS 

A.   ................................................................................................................................................................................... 1 OBJECTIVE

B.   ................................................................................................................................ 1 SOLICITATION PACKAGES DESIGNATION

B.1.   ...................................................................................................................................................................................... 1 Templates Available
B.2.   ......................................................................................................................................................................................... 2 Templates Design
B.3.   .............................................................................................................................................................................................. 2 Templates Use

C.   ..................................................................................................................................................... 3 TECHNICAL REQUIREMENTS

C.1.   ........................................................................................................................................................................................ 3 Required Software
C.2.   ......................................................................................................................................................................................... 3 Optional Software
C.3.  .......................................................................................................................................................... 3 Utilized Software Functions and Tools

D.   ........................................................................................................................................................... 3 TEMPLATES NAVIGATION

D.1.   ............................................................................................................................................................ 3 Working with Templates in MS Word
D.2.   .............................................................................................................................................................................................. 4 Creating PDFs
D.3.   .................................................................................................................................................. 8 Accessibility, Security and Professionalism
D.4.   .................................................................................................................................................................................................. 8 Other Issues

 

A. OBJECTIVE 
• Meet statutory purchasing requirements 

• Assure consistency of procurement processes throughout the State of Oklahoma 

• Reflect the professionalism of the requesting agency by providing customer friendly documents 

B. SOLICITATION PACKAGES DESIGNATION 
B.1. Templates Available 
There are four document templates available designed for use for two types of users, two versions each: 

Types - There are two types of solicitation packages to use: 

• CP - for solicitations to be processed for state agencies through DCS, Central Purchasing Division (CP) 

• AGENCY - for solicitations conducted independently by state agencies 

Versions - There are two versions to choose from within each type: 

• FULL - addresses complex solicitations with lengthy specifications, special provisions, etc 

• SHORT - addresses simple / less complex solicitations 

Table 1 - Files Titles 

 Package Version: FULL Package Version: SHORT 

Package Type: CP DCS-CP-SOLICITATION-FULL DCS-CP-SOLICITATION-SHORT 

Package Type: AGENCY DCS-AGENCY-SOLICITATION-FULL DCS-AGENCY-SOLICITATION-SHORT 
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B.2. Templates Design 
All packages share the same layout: Forms 070, 076 and 004 are followed by General Provisions. Additionally, the FULL version 
contains editable sections (from B through H) not included in the SHORT version. 

Table 2 - Templates Design 

Package Content: Package Version: FULL Package Version: SHORT 
DCS-Form-CP- 070, Solicitation Yes Yes 
DCS-Form-CP- 076, Responding Bidder Information Yes Yes 
DCS-Form-CP- 004, Certification for Competitive Bid and/or Contract Yes Yes 
Table of Contents Yes No 
General Provisions1 Yes (Se Yes ction A) 
Special Provisions2 Yes (Se No ction B) 
Solicitation Specifications Yes (Se No3 ction C) 
Evaluation Yes (Se No3 ction D) 
Instructions to Supplier Yes (Se No3 ction E) 
Checklist Yes (Se No ction F) 
Other Yes (Se No ction G) 
Price And Cost Yes (Se No ction H) 

B.3. Templates Use 
B.3.1. CP 

All acquisitions processed through CP require either template DCS-CP-SOLICITATION-FULL or DCS-CP-SOLICITATION-SHORT. 
Chose the appropriate version based on the complexity of acquisition. 

SHORT: When general provisions and PeopleSoft generated Requisition provide all information the bidder needs. State agencies are 
not requi
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red to complete this version and should submit only Requisition through PeopleSoft, which CP attaches to DCS-CP-
ATION-SHORT.  

FULL: hen an acquisition is complex, DCS-CP-SOLICITATION-FULL is used because of its multiple sections. Therefore, 
 can either: 

Use DCS-CP-SOLICITATION-FULL template to enter content of solicitation; or 

Use the DCS-CP-SOLICITATION-working template. This template is helpful in developing a complex solicitation, which 
may involve content input by multiple parties of both the state agency and Central Purchasing, i.e. specifications (see: 
Table 2, Templates Design) through numerous exchanges of a document and where at least one party cares about 
tracking changes within the document as it is being created and finalized. Upon completion, the content of a document 
from sections B forward is to be moved to DCS-AGENCY-SOLICITATION-FULL. 

Regardless of the method, state agencies must provide CP with an electronic version of the solicitation document in MS 
Word format in order to enable CP to finalize its content. CP will convert finalized document to PDF, attach the State 
agency’s Requisition and make document available to bidders. 

B.3.2. AGENCY 

All acquisitions conducted independently by a state agency require either template DCS-AGENCY-SOLICITATION-FULL or DCS-
AGENCY-SOLICITATION-SHORT. The appropriate version is chosen based on the complexity of an acquisition. 

SHORT: When general provisions and PeopleSoft generated Requisition provide all information the bidder needs. 

FULL: hen an acquisition is complex; this template contains multiple sections (see: Table 2, Templates Design) to allow the 
of information specific to a solicitation. 

Use the DCS-AGENCY-SOLICITATION-working template. This template is helpful in developing a complex solicitation, 
which may involve content input within agency, i.e. specifications (see: Table 2, Templates Design) through numerous 
exchanges of a document and where at least one party cares about tracking changes within the document as it is being 
created and finalized. Upon completion, the content of a document from sections B forward is to be moved to DCS-
AGENCY-SOLICITATION-FULL. 

 
1  General Provisions are not subject to any changes 
2  Special Provisions must not duplicate General Provisions included in the package 

pecial Provisions must be carefully considered and written to minimize the risk of protest or litigation S
3  To be included in a PeopleSoft generated Requisition 



C. TECHNICAL REQUIREMENTS 
C.1. Required Software 

• MS Office (Word) 2003 or newer 

• MS Office enhanced with the MS Office Service Pack 3 update 

C.2. Optional Software 
• CP uses Adobe Acrobat 8.0 for converting documents from MS Word (DOC) to Portable Document Format (PDF). Adobe 

Acrobat is commonly called PDF Writer. 

• CP posts solicitations on the DCS website in PDFs because Adobe Reader is a popular freeware, easily accessible for 
download and used by bidders (Note: Adobe Reader does not allow conversion of documents from MS Word to PDF). 

C.3. Utilized Software Functions and Tools 
In order to utilize solicitation packages effectively, use of the following functions is necessary  

• MS Word: “Styles and Formatting” – data entry by using predesigned styles within unprotected sections (FULL version only) 

• MS Word: “Outlining” – managing document’s table of contents (FULL version only) 

In order to provide suppliers with a solicitation package merged into one document, use of the following functions is recommended: 

• MS Word and Adobe Acrobat: “Convert to Adobe PDF” - printing from DOC to PDF 

• Adobe Acrobat: “Insert Pages” 

• Adobe Acrobat: “Accessibility” 

• Adobe Acrobat: “Secure” (optional) 

D. TEMPLATES NAVIGATION 
D.1. Working with Templates in MS Word 
All four templates (see: Table 1) are protected as “Filling in forms” enabling data entry in designated form fields of SHORT and FULL 
versions, and unprotected sections from B through H of FULL version only.  

The FULL version requires application of following functions of MS Word software: 
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• Data Entry, Copying and Pasting: Sections from B forward are unprotected enabling data entry, and copying and pasting 
content from different sources. Use predesigned styles (command: Format > Styles and Formatting) in order to assure 
consistent formatting throughout the document. Predesigned styles address: numbering / outlining / bulleting, regular text 
format and footnotes. For example, Figure 1 indicates that word “None” is specified as “Regular Text”. “H. PRICE AND 
COST” right above it was formatted as “A. OUTLINE-LEVEL 1”. 

Content formatted with LEVEL 1 and Level 2 is linked to a document’s table of contents. Therefore, it is recommended to 
only use them to format sections’ titles and sub-titles.  

Avoid using Enter to create space between paragraphs. Use the space before and space after; command: Format > 
Paragraph > Spacing. 

Figure 1 – Using Styles 

 
 



• Using Tables: Do not use tabs and spaces to create tables. Use command: Table > Insert > Table. Avoid letting table rows 
break across a page but allow tables that go beyond one page repeat header rows; command: Table > Table Properties > 
Row 

• Table of Contents: The table of contents enhances document’s navigation. It is electronically generated by the first two 
outline levels available in Styles and Formatting. When the document’s content and its Styles and Formatting adjustment is 
completed, update the table of contents. Click to the left of the table of contents and press F9 on the keyboard. 

Figure 2 – Updating Table of Contents 

 

• Links: Hyperlink all email and web addresses within the document by providing the specific address, i.e. www.dcs.ok.gov 
instead of DCS website. Otherwise a link will not work when MS Word document is converted to PDF. 

• Images: If an image is part of the solicitation (command: Insert > Picture), provide an alternate text to the image by clicking 
on the image and following command: Format > Picture > Web, or double click on the image and follow command: Web. 
This step is included to comply with accessibility standards. 

Figure 3 – Proving Alternate Text for Images 

 

D.2. Creating PDFs 
• Conversion Settings: Make sure that conversion settings enable producing accessible PDFs;  

command: Adobe PDF > Convert to Adobe PDF > Settings 

command: Adobe PDF > Convert to Adobe PDF > Bookmarks > Check Outline Level 1 and 2 

Figure 4 – Conversion Settings 
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• Printing MS Word document (DOC) into Adobe (PDF): click “Convert to Adobe PDF” icon from the window menu, or follow 
command: Adobe PDF > Convert to Adobe PDF. 

Do not use command: File > Print > Adobe PDF because this method of conversion reduces PDF’s accessibility. 

Figure 5 – Converting to PDF 

 

Note: Solicitation document (in MS Word) and state agency’s Requisition or Purchase Order (in PDF) can be available to 
bidders as two separate documents instead of one for acquisitions independently conducted by a state agency, regardless 
of the version used, and when the agency does not have Acrobat Adobe. 

• Scanning Pages: Scanned documents are hardly ever accessible and often not easy to read because content is blurry and 
pages skewed. Document can be made accessible but it is tedious processes. Therefore require specifications (and other 
sections) to be delivered in an accessible and editable electronic format to ensure final PDFs readability and accessibility. 

Ensure scanned pages readability, prior to combining the final solicitation package: 

commands 1 & 2: Document > OCR Text Recognition > Recognize Text Using OCR > Primary OCR Language: English (US) 
commands 3 & 4: Advanced > TouchUp Reading Order > mark text - 4a > click “Text” on the panel - 4b 

Figure 6 – Recognizing and Tagging Text of Scanned Documents 
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4.  

• Ink Signatures: If an ink signed document is to be scanned and posted on a website, consider releasing the electronic copy 
with the following statement: “[originally signed document on file]” in lieu of signature. The Statement must be inserted 
prior to creating PDF to increase document’s accessibility. 

Figure 7 – Posting Accessible Documents without Ink Signatures 

 

• Adding Pages to a PDF file: Adding pages is possible as long as the main PDF (the file where pages are added to) is not 
protected, command: Document > Insert Pages. 

Figure 8 – Adding Pages to a PDF file 

 

• Language: specify language of a created PDF to allow accessibility software to recognize the text in the document; 
command: File > Properties > Language > English US 
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Figure 9 – Specifying Language 

   
• Reading Order: specify reading order of a created PDF to allow accessibility softwares to read the content in a logical order; 

command: click “Pages” -1 > highlight desired pages (Ctrl+A highlights all) – 2 > check “Options” - 3 > Page Properties - 4 > 
Tab Order > check row, column or document structure order as applicable 

Figure 10 – Specifying Order 

   
• Protecting PDF (optional): secure PDF only if meets accessibility requirements (check accessibility of a document with the 

following command: Advanced > Accessibility > Full Check); click “Secure” icon from the window menu or use command: 
Advanced > Security. Make sure to check “Enable text access for screen reader devices for the visually impaired’. 

D.3. Accessibility, Security and Professionalism 
It is advisable to have all documents saved in editable format in a safe location to be able to conduct additional accessibility 
adjustments as needed. 

D.4. Other Issues 
For other issues, utilize function Help or press key F1 both in MS Word and Adobe. 
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